CleanUp

Copyright © 2017 by Eugen Höglinger. All Rights Reserved.


Einführung

Hier sind alle wichtigen Informationen zu Installation und Betrieb zusammengefaßt:

  • Über CleanUp
  • Systemvoraussetzung
  • Installation
  • Lizenzabkommen
  • Haftungsausschluß
  • Copyright


Über CleanUp

Das Programm CleanUp dient zum Bereinigen des Teamcenter Client Caches, sowie zum Bereinigen des temporären Verzeichnisses.

Es kann eigenständig ausgeführt oder aus einem Batch-Script heraus aufgerufen werden.

CleanUp hat zwei Funktionen:

  • Bereinigen des Teamcenter Client Cache.
  • Bereingen des Temporären Verzeichnisses.

Das Temporäre Verzeichnis kann auf zwei Arten bereinigt werden:

  • Das ganze Temporäre Verzeichnis bereinigen.
  • Nur temporäre NX-Dateien bereinigen.

Bei den temporären NX-Dateien stehen zwei zusätzliche Optionen zur Verfügung:

    • Alle NX Dateien bereinigen.
    • Nur NX Datein bereinigen die älter als n-Tage sind.


Systemvoraussetzung

  • Betriebssytem Win10, Win8, Win7, Vista oder XP (32- und 64-Bit-Version)
  • Microsoft .NET Framework 4.5
  • Min. 520 KB freier Speicherplatz auf der Festplatte


Installation

Für die Installation gibt es keine eigene Installationsroutine.

Sie müssen lediglich den Ordner CleanUp in ein beliebiges Verzeichnis kopieren.

Um den Aufruf zu erleichtern, können Sie von der Datei CleanUp.exe eine Verknüpfung auf dem Desktop oder im Startmenü von Windows erstellen.


Lizenzabkommen

Das Programm ist Freeware. Es unterliegt keiner Einschränkung. Es darf bis auf Wiederruf frei verwendet und weitergegeben werden.


Haftungsausschluß

Diese Software wurde vor der Veröffentlichung intensiv getestet. Für die Verwendungsfähigkeit und Fehlerfreiheit kann allerdings keine Garantie übernommen werden. Jede Haftung für direkte, indirekte, verursachte oder gefolgte Schäden, die durch Verwendung dieses Programms entstehen könnten, ist ausgeschlossen.


Copyright

Alle Inhalte dieses Softwarepaketes, insbesondere Programmcode, Texte, Fotografien, und Grafiken, unterliegen dem Schutz des Urheberrechtes (Copyright). Das Urheberrecht liegt, soweit nicht ausdrücklich anders gekennzeichnet, bei Eugen Höglinger. Bitte fragen Sie mich (eugen@hoeglinger.name) falls Sie die Inhalte des Produktes, wenn auch nur teilweise, verändern möchten.

Wer gegen das Urheberrecht verstößt, macht sich gem. dem Urhebergesetz strafbar. Er wird zudem kostenpflichtig abgemahnt und muss Schadenersatz leisten.

2017


Programmoberfläche

Die Programmoberfläche gliedert sich in sechs Bereiche.

Nummer | Bereich
 | Menüleiste
 | Auswahl
 | Optionen temporäres Verzeichnis
 | Optionen NX-Dateien
 | Status
 | Aktion


Menüleiste

Die Menüleiste beinhaltet zwei Menüpunkt:

  • Aktion
  • Hilfe


Aktion

Im Menü Aktion sind zwei Funktion:

  • Start
  • Abbruch

Von der Funktion sind beide Aktionen ident mit den Funktionen auf der Programmoberfläche.


Start

Nach Auswahl des Menüpunktes Start, wird die Bereinigungsaktion ausgeführt.

Sobald die Aktion fertig ist, wird eine entsprechende Information ausgegeben. Nach bestätigen der Information, wird das Programm beendet.

Hinweis: Sie können den Menüpunkt nur dann auswählen, wenn Sie im Bereich Auswahl mindestens einen Punkt selektiert haben.


Abbruch

Wenn Sie den Menüpunkt Abbruch auswählen, dann wird das Programm sofort beendet, unabhängig davon was Sie vorher eingestellt haben.


Logdatei

Durch Auswahl dieses Menüpunktes, können Sie sich die zuletzt erzeugte Logdatei im Editor anzeigen lassen. In der Logdatei sind alle Dateien/Verzeichnisse vermerkt die nicht gelöscht werden konnten.

Wird die Logdatei nicht gefunden, dann wird eine Fehlermeldung ausgegeben. Folgenden Gründe verhindern das die Logdatei gefunden wird:

  • Noch keine Logdatei vorhanden, weil alle Dateien/Verzeichnisse gelöscht wurden.
  • Die Logdatei selbst wurde gelöscht.
  • Die Logdatei wurde in der Zwischenzeit verschoben.

Wird der Editor nicht gefunden, dann wird eine Fehlermeldung ausgegeben. In diesem Fall sollten Sie ihre Windows Installation überprüfen, weil für die Anzeige der Windows Editor (Notepad) verwendet wird.


Hilfe

Der Menüpunkt Hilfe beinhaltet zwei Funktionen:

  • Hilfe
  • Info


Hilfe

Über diesen Menüpunkt öffnen Sie diese Hilfe.


Info

Die Funktion Info zeigt wichtige Informationen zum Programm an:

  • Den Programmnamen
  • Die Versionsnummer
  • Die Verzichtserklärung

Schaltflächen

Schliessen | Schliesst den Dialog.
Export | Über diese Schaltfläche können Sie die verzichtserklärung exportieren und an einem beliebigen Ort abspeichern.


Auswahl

Im Bereich Auswahl definieren Sie welche Reinigungsaktionen ausgeführt werden:

  • Teamcenter Client Cache
  • Temp Verzeichnis


Teamcenter Client Cache

Wenn Sie Teamcenter Client Cache auswählen, dann werden folgende Aktionen ausgeführt:

  • NX oder Ideas wird beendet.
  • Teamcenter wird beendet.
  • Alle Java Prozesse werden beendet.
  • Das Teamcenter Cache Verzeichnis wird gelöscht.
  • Alle temporären Teamcenter Dateien und Verzeichnisse werden gelöscht.


Temp Verzeichnis

Wenn Sie Temp Verzeichnis auswählen, dann wird das temporäre Verzeichnis bereinigt. Welche Daten gelöscht werden, bestimmen Sie mit den folgenden Optionen:

  • Das temporäre Verzeichnis, welches gelöscht werden soll.
  • Alle Dateien
  • Nur NX-Dateien


Optionen temporäres Verzeichnis

Mit den Optionen bestimmen Sie:

  • Das temporäre Verzeichnis
  • Die Dateien welche bearbeitet


Das temporäre Verzeichnis

Im Eingabefeld können Sie den vollständigen Pfad eines beliebigen temporären Verzeichnisses angeben.

Voreingestellt ist der Standard-Pfad C:/temp.

Alternativ dazu können Sie rechts vom Eingabefeld auf die Schaltfläche [image] klicken und im Dialog ein beliebiges Verzeichnis auswählen.


Dateien

Sie können auswählen welche Dateien gelöscht werden sollen:

  • Alle Dateien
  • Nur NX-Dateien

Hinweis: Haben Sie nur NX-Dateien ausgewählt, dann werden nur Dateien gelöscht, welche mit NX assoziert sind.


Alle Dateien

Haben Sie Option ausgewählt, dann werden alle Dateien und Verzeichnisse im temporären Verzeichnis gelöscht.

Hinweis: Dateien oder Verzeichnisse die gerade in Verwendung sind, werden nicht gelöscht.


Nur NX-Dateien

Haben Sie diese Option ausgewählt, dann werden nur Dateien gelöscht die mit NX assoziiert werden.

Die folgenden Dateien sind als NX-Dateien definiert:

  • *.prt
  • *.syslog
  • *.rolbin
  • *.plmxml
  • *.vvi
  • *_pal
  • *_jt.log
  • Log*.tmp
  • nx*.tmp
  • OC*.tmp
  • ugs_router*

Sie können außerdem das Alter der NX-Dateien bestimmen, die gelöscht werden sollen.


Optionen NX-Dateien

Haben Sie die Option Nur NX-Dateien ausgewählt, dann können Sie in den NX-Temp Optionen mit den nachfolgend beschriebenen Optionen festlegen, wie alt die NX-Dateien sein müssen damit sie gelöscht werden.

  • Alle
  • Dateien älter als n-Tage


Alle

Haben Sie die Option Alle ausgewählt, dann werden alle NX-Dateien gelöscht, unabhängig davon wie alt sie sind.


Dateien alter als n-Tage

Haben Sie die Option Dateien älter als n-Tage ausgewählt, dann werden nur NX-Dateien gelöscht die älter als n-Tage sind.

Sie können vordefinierte Werte aus der Liste auswählen oder Sie geben einen beliebigen, ganzzahligen, positiven Wert ein.

Hinweis: Es hat sich als hilfreich erwiesen, nur Dateien die älter als 3 Tage sind zu löschen. Wenn Fehler auftreten, ermöglicht dies auch die Einsicht in ältere Logdateien.


Status

Der Bereich Status zeigt den aktuelle Fortschritt als Fortschrittsbalken an.

Unter dem Fortschrittsbalken wird angezeigt welche Datei bzw. welches Verzeichnis gerade gelöscht wird.


Aktion

Der Bereich Aktion enthält die zwei Schaltflächen:

  • Start
  • Abbruch


Start

Nach anklicken der Schaltfläche Start, wird die Bereinigungsaktion ausgeführt.

Sobald die Aktion fertig ist, wird eine entsprechende Information ausgegeben. Nach bestätigen der Information, wird das Programm beendet.

Hinweis: Sie können die Schaltfläche nur dann auswählen, wenn Sie im Bereich Auswahl mindestens einen Punkt selektiert haben.


Abbruch

Wenn Sie die Schaltfläche Abbruch anklicken, dann wird das Programm sofort beendet, unabhängig davon was Sie vorher eingestellt haben.


Programmaufruf

Mit den folgenden Schritten führen Sie eine Bereinigung durch:

  • Rufen Sie das Programm auf indem Sie doppelt auf [image] klicken.
  • Wählen Sie die gewünschte Funktion aus.
  • Wählen Sie entsprechende Optionen aus.
  • Starten Sie die Bereinigung indem Sie auf die Schaltfläche Start klicken.


Scriptaufruf

In einem Batch Script können Sie das Programm wie folgt aufrufen:

CleanUp.exe [-cachefolder=<Cache-Verzeichnis>] [-tempfolder=<Temp-Verzeichnis> [-nxonly [-days=<Tage>]]]

Eventuell müssen Sie vor dem Programmaufruf noch den Pfad eingeben in dem das Programm liegt.

Nachfolgend werden die einzelnen Übergabeparameter beschrieben:

Parameter | Optional | Beschreibung
-cachefolder=<Cache-Verzeichnis> | ja | Verzeichnis des Teamcenter Client Caches, dessen Inhalt gelöscht werden soll. Wird der Wert nicht angegeben, dann werden keine Client Cache Dateien gelöscht.
<Cache-Verzeichnis> | nein | Vollständiger Pfad des Teamcenter Client Cache Verzeichnisses.
-tempfolder=<Temp-Verzeichnis> | ja | Temporäres Verzeichnis, dessen Inhalt gelöscht werden soll. Wird der Wert nicht angegeben, dann werden keine Daten aus dem temporären Verzeichnis gelöscht.
<Temp-Verzeichnis> | nein | Vollständige Pfad des temporären Verzeichnisses.
-nxonly | ja | Es werden nur NX-Dateien aus dem temporären Verzeichnis gelöscht. Wird der Wert nicht angegeben, dann werden alle Dateien gelöscht.
-days=<Tage> | ja | Löscht nur Dateien die alter als <Tage> sind. Wird der Wert nicht angegeben, dann werden alle Dateien gelöscht. Wird der Wert angegeben, dann muss auch der Wert -nxonly angegeben werden.
<Tage> | nein | Gibt an wie viele Tage eine Datei mindestens alt sein muss, damit sie gelöscht wird.


Unlöschbare Dateien/Verzeichnisse

Es ist kein Programmfehler wenn nicht alle Dateien oder Verzeichnisse gelöscht wurden.

Es kann unterschiedliche Ursachen haben warum Dateien oder Verzeichnisse nicht gelöscht werden können, z.B.:

  • Fehlende Rechte
  • Die Datei oder das Verzeichnis ist noch in Verwendung
  • Ein Verzeichnis ist nicht vollständig leer
  • usw.

Die Namen der Dateien oder Verzeichnisse die nicht gelöscht werden konnten, werden vom Programm in die Textdatei CleanUp.log eingetragen. Die Datei wird in dem Verzeichnis abgelegt, welches als Temporäres-Verzeichnis definiert ist (meist C:/temp). Die Datei wird bei jedem Start von CleanUp neu und auch nur dann angelegt, wenn Elemente nicht gelöscht werden konnten. Bereits bestehende Dateien werden überschrieben.

Die Datei CleanUp.txt kann mit jedem beliebigen Texteditor, z.B. Notepad, geöffnet, angesehen und beliebig weiterbearbeitet werden.